Cari

Lintang Sumunar

Ojo Turu Sore kaki….ono dewo nglanglang jagad….

Kategori

Mikrotik

all about mikrotik

Limit max connection number IDM dengan Mikrotik

sewot juga lihat user download dengan IDm dan diset max connection number nya max (biasanya 16), walaupun sudah dilimit bandwidth per usernya, tapi kadang-kadang bikin jaringan lemot juga

gak sengaja nemu trik dari http://forum.mikrotik.com/viewtopic.php?f=2&t=55213

ternyata maknyus juga…..

/ip firewall filter
add action=drop chain=forward comment=”exe” connection-limit=\
1,32 content=.exe disabled=no protocol=tcp
add action=drop chain=forward comment=”rar” connection-limit=\
1,32 content=.rar disabled=no protocol=tcp

tinggal tambahkan sesuai ekstension file yang mau dilimit, dengan filter ini IDM hanya akan jalan dengan satu koneksi aja

transparent trafic shaper mikrotik buat Yfi Hotspot

sharing sedikit tentang mikrotik bridge untuk bandwidth shaping yfi hotspot dengan koneksi speedy 2M

/ interface bridge
add name=”bridge1″
/ interface bridge port
add interface=ether2 bridge=bridge1
add interface=ether3 bridge=bridge1
/ interface bridge settings
set use-ip-firewall=yes

/ ip firewall mangle
add chain=prerouting protocol=tcp dst-port=80,53 action=mark-connection \
new-connection-mark=http_conn passthrough=yes
add chain=prerouting connection-mark=http_conn action=mark-packet \
new-packet-mark=http passthrough=no
add chain=prerouting p2p=all-p2p action=mark-connection \
new-connection-mark=p2p_conn passthrough=yes
add chain=prerouting connection-mark=p2p_conn action=mark-packet \
new-packet-mark=p2p passthrough=no
add chain=prerouting action=mark-connection new-connection-mark=other_conn \
passthrough=yes
add chain=prerouting connection-mark=other_conn action=mark-packet \
new-packet-mark=other passthrough=no
add chain=forward protocol=tcp dst-port=22,443,3990 action=mark-connection \
new-connection-mark=billing passthrough=yes
add chain=forward connection-mark=billing action=mark-packet \
new-packet-mark=billing passthrough=no
add chain=forward  action=mark-connection new-connection-mark=squid passthrough=yes dscp=12
add chain=forward connection-mark=squid action=mark-packet \
new-packet-mark=squid passthrough=no

/ queue simple
add name=”main” target-addresses=10.1.0.0/24 max-limit=unlimited/unlimited
add name=”http” parent=main packet-marks=http max-limit=512000/1700000 priority=1
add name=”p2p” parent=main packet-marks=p2p max-limit=64000/64000 priority=8
add name=”other” parent=main packet-marks=other max-limit=64000/256000 priority=4
add name=”billing” parent=main packet-marks=billing max-limit=10240000/10240000 priority=8
add name=”squid” parent=main packet-marks=squid max-limit=10240000/10240000 priority=8

untuk mengatasi IDM saya menggunakan delaypool squid, squid jadi satu sama yfi dan mikrotik ini saya tempatkan setelah tun0

oh ya.. tambahkan pada queue list, pada tab queue type, klik tanda +, isikan type name download, Kind pcq, centang Dst address, lalu klik ok, ulangi proses yg sama dengan type name upload centang src address
lalu pada masing2 queue simple klik dua kali, pada tab advance rubah queue type menjadi download pada target download dan upload pada target upload

dikutip dari post-ku di http://opensource.telkomspeedy.com/forum/viewtopic.php?id=8439&p=20, sebagai pengingat saja

Load balancing pcc mikrotik

script load balancing ini hasil utak-atik dari berbagai sumber, antara lain

forum mikrotik, blog-blog tentang mikrotik yang banyak sekali hingga aku lupa alamat blognya, terima kasih buat semuanya….

/interface set ether1 name=local
/interface set ether2 name=speedy1
/interface set ether3 name=speedy2

/ip address add address add=192.168.1.1/24 interface=local
/ip address add address add=192.168.2.2/30 interface=speedy1
/ip address add address add=192.168.3.2/30 interface=speedy2

/ip dns set servers=203.134.193.74,202.134.0.155

/interface pppoe-client
add ac-name=”” add-default-route=no allow=pap,chap,mschap1,mschap2 comment=”” \
dial-on-demand=no disabled=no interface=speedy1 max-mru=1480 max-mtu=1480 \
mrru=disabled name=”PPPoE-1″ user=”xxxxxxxxxx@telkom.net” password=”xxxxxx” profile=default \
service-name=”” use-peer-dns=no

add ac-name=”” add-default-route=no allow=pap,chap,mschap1,mschap2 comment=”” \
dial-on-demand=no disabled=no interface=speedy2 max-mru=1480 max-mtu=1480 \
mrru=disabled name=”PPPoE-2″ user=”xxxxxxx@telkom.net” password=”xxxxx” profile=default \
service-name=”” use-peer-dns=no

/ip route add dst-address=0.0.0.0/0 gateway=PPPoE-1 distance=1 check-gateway=arp
/ip route add dst-address=0.0.0.0/0 gateway=PPPoE-2 distance=2 check-gateway=arp

/ip firewall mangle add chain=input in-interface=speedy1 action=mark-connection new-connection-mark=jalur01
/ip firewall mangle add chain=input in-interface=speedy2 action=mark-connection new-connection-mark=jalur02

/ip firewall mangle add chain=output connection-mark=jalur01 action=mark-routing new-routing-mark=ke_jalur01
/ip firewall mangle add chain=output connection-mark=jalur02 action=mark-routing new-routing-mark=ke_jalur02

/ip firewall mangle add chain=prerouting dst-address-type=!local in-interface=local per-connection-classifier=both-addresses:2/0 action=mark-connection new-connection-mark=jalur01 passthrough=yes
/ip firewall mangle add chain=prerouting dst-address-type=!local in-interface=local per-connection-classifier=both-addresses:2/1 action=mark-connection new-connection-mark=jalur02 passthrough=yes

/ip firewall mangle add chain=prerouting connection-mark=jalur01 in-interface=local action=mark-routing new-routing-mark=ke_jalur01
/ip firewall mangle add chain=prerouting connection-mark=jalur02 in-interface=local action=mark-routing new-routing-mark=ke_jalur02

/ip route add dst-address=0.0.0.0/0 gateway=PPPoE-1 routing-mark=ke_jalur01 check-gateway=arp
/ip route add dst-address=0.0.0.0/0 gateway=PPPoE-2 routing-mark=ke_jalur02 check-gateway=arp

/ip route add dst-address=0.0.0.0/0 gateway=PPPoE-1 distance=1 check-gateway=arp
/ip route add dst-address=0.0.0.0/0 gateway=PPPoE-2 distance=2 check-gateway=arp

/ip firewall nat
add chain=srcnat action=masquerade out-interface=PPPoE-1 comment=”” disabled=no
add chain=srcnat action=masquerade out-interface=PPPoE-2 comment=”” disabled=no

Blog di WordPress.com.

Atas ↑